[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Crazy laptop behavior

I just resolved a very baffling internet problem with my CentOS 7 laptop.
Last night I started having problems connecting to a lot of web sites.
Firefox gave up trying to refresh connections to well-known sites --
including those I'd been talking to moments before.

Diagnostic results were wierd. DNS worked, but traceroute would go no
farther than the laptop itself. Web sites outside the AT&T system refused
to connect. Only Facebook and Corvette Forum would connect with no issues.

My Windows 10 desktop PC worked perfectly, as did the IP utilities from
the U-verse Residential Gateway router. I checked every inch of the
Ethernet cable from one plug to the other, and moved it to another port on
the Etherswitch. I rebooted the laptop -- twice -- and even changed the AC
power adapter.

Finally, I pulled down the NetworkManager applet and noticed that both
enp0s25 Ethernet and wlp3s0 wifi interfaces were enabled. Two active
internet connections with no arbitration mechanism to favor one over the
other. No wonder things were acting badly.

To solve the problem I simply disabled the enp0s25 Ethernet port, leaving
only the wlp3s0 wifi active. A few minutes later I disabled the wifi and
enabled the Ethernet port. In each case, communications were perfect.

If you ever see crazy behavior with your laptop like this, try checking
your active network ports. As in "Highlander", there can be only one.

--Doc Savage
  Fairview Heights, IL

To unsubscribe, send email to majordomo@silug.org with
"unsubscribe silug-discuss" in the body.